Removing BOB support

Post Reply
User avatar
zzz
Posts: 148
Joined: 31 Mar 2018 13:15

Removing BOB support

Post by zzz »

See http://zzz.i2p/topics/2973

Proposed timetable:

- 2020-08: Note deprecated on http://i2p-projekt.i2p/en/docs/api/bob (done)

- 0.9.48 ? Add wrapper and router log warning to BOB saying it's deprecated

- 0.9.48 ? Remove from default clients.config but still include BOB.jar (affects new installs only)

- 0.9.49 ? Remove from BOB.jar from installer and package builds (affects new installs and packages only)

- 0.9.50 ? Remove from i2pupdate.zip (no more updates)

- 0.9.51 ? Remove from source tree

Please comment here or on http://zzz.i2p/topics/2973, especially if you're currently using or developing a BOB application. All new applications should be using SAMv3.
Post Reply